Hinzufügen und Löschen von Elementen der Werkzeugsammlung

So fügen Sie der Werkzeugsammlung neue Elemente hinzu

  1. Klicken Sie in der Werkzeugsammlung auf die Registerkarte, der das Element hinzugefügt werden soll.

  2. Wählen Sie aus dem Menü Extras den Befehl Werkzeugsammlung anpassen.

    Obwohl Sie Elemente in Ihre Werkzeugsammlung ziehen können, gibt Ihnen das Dialogfeld Werkzeugsammlung anpassen die Möglichkeit, die Registrierung zu durchsuchen und Steuerelemente und Applets zu finden.

    Anmerkung Sie können auch anderen Text oder HTML-Elemente im Editor auswählen und in die Werkzeugsammlung ziehen, um HTML-Fragments zu erstellen.

  3. Aktivieren Sie das Kontrollkästchen links neben dem jeweils hinzuzufügenden Element.

    Wenn das Element nicht in der Liste enthalten ist, klicken Sie auf Durchsuchen, um es zu finden.

  4. Klicken Sie auf OK, um das Element bzw. die Elemente hinzuzufügen.

    Sie werden auf der entsprechenden Registerkarte in der Werkzeugsammlung angezeigt.

So löschen Sie ein Element aus der Werkzeugsammlung

  1. Wählen Sie aus dem Menü Extras den Befehl Werkzeugsammlung anpassen.

  2. Deaktivieren Sie das Kontrollkästchen links neben dem Element.

  3. Klicken Sie auf OK, um das Element zu löschen.

    Das Element der entsprechenden Registerkarte wird aus der Werkzeugsammlung entfernt.


Hinzufügen, Löschen und Umbenennen der Registerkarten der Werkzeugsammlung

Die Werkzeugsammlung enthält standardmäßig zwei Registerkarten: die Registerkarte Allgemein und die Registerkarte HTML. Wenn Sie der Werkzeugsammlung ein Element hinzufügen, wird dieses auf der aktuellen Registerkarte angezeigt. Sie können aber eigene Registerkarten in der Werkzeugsammlung anlegen, damit Sie Ihre Werkzeuge anhand der durchzuführenden Aufgaben ordnen können.

So fügen Sie der Werkzeugsammlung eine Registerkarte hinzu

  1. Klicken Sie mit der rechten Maustaste auf die Werkzeugsammlung.

  2. Wählen Sie Registerkarte hinzufügen.

    Der Werkzeugsammlung wird eine leere Registerkarte hinzugefügt.

  3. Geben Sie an der blinkenden Einfügemarke am unteren Rand der Werkzeugsammlung einen Namen für die Registerkarte ein, und drücken Sie EINGABE.

Beim Erstellen einer neuen Registerkarte wird automatisch ein Zeigerwerkzeug

als erstes Element hinzugefügt.

So löschen Sie eine der Werkzeugsammlung hinzugefügte Registerkarte

  1. Klicken Sie in der Werkzeugsammlung mit der rechten Maustaste auf die zu löschende Registerkarte.

  2. Wählen Sie Registerkarte löschen.

So benennen Sie eine der Werkzeugsammlung hinzugefügte Registerkarte um

  1. Klicken Sie in der Werkzeugsammlung mit der rechten Maustaste auf die Registerkarte, die umbenannt werden soll.

  2. Wählen Sie Registerkarte umbenennen.

  3. Geben Sie den neuen Namen der Registerkarte ein.

So ordnen Sie die Registerkarten in der Werkzeugsammlung neu

  • Ziehen Sie sie nach oben oder unten an eine neue Stelle.


Anfügen und Trennen von Prozessen

Bei auf Komponenten basierenden Client-/Server- und Internet-Anwendungen laufen Teile der Anwendung möglicherweise in einem separaten Prozess, ja möglicherweise sogar auf einem anderen Computer, ab. Im Dialogfeld Prozesse können Sie außerhalb des Prozesses befindliche Komponenten debuggen, indem Sie sie an eine Debug-Sitzung anfügen.

So fügen Sie einen neuen Prozess an

  1. Wählen Sie aus dem Menü Debuggen den Befehl Prozesse. Das Dialogfeld Prozesse wird geöffnet.

  2. Wählen Sie einen Prozess aus der Liste Prozesse aus. Die Liste zeigt alle Prozesse, die gedebuggt werden können und momentan auf Ihrem Computer ausgeführt werden.

    Wenn eine Verbindung zu einem Netzwerk besteht, können Sie außerdem Prozesse auf einem anderen vernetzten Computer anzeigen und anfügen, indem Sie den Namen des Computers aus der Liste Computer wählen oder auf die Schaltfläche Computer klicken, um das Netzwerk zu durchsuchen.

  3. Klicken Sie auf die Schaltfläche Anfügen.

So trennen Sie einen Prozess

  4. Wählen Sie aus dem Menü Debuggen den Befehl Prozesse. Das Dialogfeld Prozesse wird geöffnet.

  5. Wählen Sie einen Prozess aus der Liste Debuggte Prozesse.

  6. Klicken Sie auf die Schaltfläche Trennen.


Fortfahren nach einem Fehler

Obwohl Sie häufig eine Korrektur eingeben und die Ausführung des Programms mit der gleichen Zeile fortsetzen können, die die Ausführung anhielt, werden alle Änderungen ignoriert, bis Sie die Debug-Sitzung beenden und neu starten.

So setzen Sie die Ausführung aus dem Haltemodus heraus fort

  • Wählen Sie aus dem Menü Debuggen den Befehl Fortfahren.

Bei einigen Änderungen (in der Regel beim Ändern von Variablendeklarationen oder Hinzufügen neuer Variablen oder Prozeduren) ist ein Neustart erforderlich. In diesem Fall wird eine Meldung eingeblendet, die Sie fragt, ob neu gestartet werden soll.


Steuern von Threads

In einer Multithreading-Anwendung können Sie zu Debugzwecken über das Thread-Fenster zwischen den Ausführungs-Threads wechseln. Sie können zu einem bestimmten Zeitpunkt nur einen Ausführungs-Thread debuggen.

Sie können zwischen den Threads wechseln, indem Sie sie in der Thread-Liste auswählen. Der Inhalt der anderen zum Debuggen verwendeten Fenster ändert sich entsprechend dem gewählten Thread.

So zeigen Sie das Thread-Fenster an

  • Wählen Sie aus dem Untermenü Debug-Fenster des Menüs Ansicht den Befehl Threads.


Erstellen benutzerdefinierter Arbeitsbereiche

Sie können benutzerdefinierte Arbeitsbereiche erstellen, die als Fensterlayouts bezeichnet werden.

So speichern Sie ein Fensterlayout

  1. Ordnen Sie die Fenster im Arbeitsbereich an.

  2. Wählen Sie aus dem Menü Ansicht den Befehl Fensterlayout definieren.

  3. Geben Sie den Namen des neuen Fensterlayouts im Dialogfeld Fensterlayout definieren ein.

    Das Fensterlayout wird gespeichert, wenn Sie Ansichten ändern, damit Sie zu ihm zurückkehren können.

So öffnen Sie ein gespeichertes Fensterlayout

  • Wählen Sie aus dem Menü Ansicht den Befehl Fensterlayout definieren.

So weisen Sie eine Ansicht zu

  1. Wählen Sie aus dem Menü Ansicht den Befehl Fensterlayout definieren.

  2. Wählen Sie die zuzuweisende Ansicht aus der Liste Ansichten des Dialogfelds Fensterlayout definieren aus.

  3. Klicken Sie auf die Schaltfläche Übernehmen.

Ihr Fensterlayout wird außerdem jedes Mal gespeichert, wenn Sie zwischen dem Entwurfsmodus, dem Debugmodus und dem Modus Ganzer Bildschirm wechseln. Die Standardlayouts für das Entwurfs- und das Debug-Fenster sind immer im Dialogfeld Fensterlayout definieren oder im Feld Fensterschnittstelle speichern/laden auf der Symbolleiste Fensterschnittstelle verfügbar.


Grundlagen des Debuggens

Der Vorgang zum Finden und Beheben von Fehlern in einer Anwendung wird als Fehlerbehebung oder Debuggen bezeichnet. Die Debugfunktionen der Umgebung unterstützen Haltepunkte, Halteausdrücke, Überwachungsausdrücke und die Möglichkeit, sich Anweisung für Anweisung bzw. Prozedur für Prozedur durch den Code zu bewegen und die Werte von Variablen und Eigenschaften anzuzeigen. Viele der in der Entwicklungsumgebung unterstützten Sprachen enthalten außerdem spezielle Debugfunktionen, wie z.B. die Fähigkeit zum Bearbeiten und Fortfahren, die Einstellung der als nächste auszuführenden Anweisung und das Testen von Prozeduren, während sich die Anwendung im Haltemodus befindet.

Die Debugtools wurden konzipiert, um Ihnen bei folgenden Problemen behilflich zu sein:

  • Kompilierungsfehler, die das Resultat von falsch konstruiertem Code sind. Wenn Sie zur Entwurfszeit ein Schlüsselwort falsch eingeben, notwendige Interpunktionszeichen auslassen oder einen öffnenden Bezeichner ohne den dazugehörigen schließenden Bezeichner setzen, werden diese Fehler beim Kompilieren der Anwendung festgestellt.

  • Laufzeitfehler, die auftreten, während die Anwendung ausgeführt wird und die Umgebung eine Operation feststellt, die nicht ausgeführt werden kann. Ein Beispiel hierfür ist die Division durch Null.

  • Logische Fehler, die auftreten, wenn eine Anwendung nicht auf die beabsichtigte Art und Weise funktioniert. Eine Anwendung kann syntaktisch gültigen Code enthalten und ausgeführt werden, ohne ungültige Operationen durchzuführen, und dennoch falsche Ergebnisse liefern. Sie müssen die Anwendung testen und die Ergebnisse analysieren, um zu prüfen, ob die Anwendung sich ordnungsgemäß verhält.

Debugtools liefern eine Momentaufnahme des aktuellen Zustands Ihrer Anwendung, darunter:

  • Das Erscheinungsbild der Benutzeroberfläche.

  • Die Werte von Variablen und Ausdrücken.

  • Aktive Prozeduraufrufe.

Es gibt vier Hauptfenster, die Sie beim Testen Ihrer Anwendung verwenden:

  • Im Direktfenster können Sie die Werte von Variablen ändern, damit Sie die Auswirkungen Ihrer Änderungen sofort sehen können. Wenn die Anwendung sich im Haltemodus befindet, können Sie Ausdrücke durch eine Eingabe im Direktfenster auswerten.

  • Im Überwachung-Fenster werden die aktuellen Überwachungsausdrücke angezeigt, bei denen es sich um Ausdrücke handelt, deren Werte Sie beim Ausführen des Codes überwachen möchten. Das Überwachungsfenster kann nur dann einen Wert für einen Überwachungsausdruck anzeigen, wenn die aktuelle Anweisung sich im angegebenen Kontext befindet. Andernfalls wird in der Wert-Spalte eine Meldung angezeigt, dass die Anweisung nicht im Kontext gegeben ist.

  • Im Lokal-Fenster wird der Wert von beliebigen Variablen innerhalb des Gültigkeitsbereichs der aktuellen Prozedur angezeigt. Während die Ausführung von Prozedur zu Prozedur wechselt, ändert sich der Inhalt des Lokal-Fensters, so dass nur die für die aktuelle Prozedur gültigen Variablen wiedergegeben werden.

  • Im Ausgabe-Fenster werden zur Laufzeit Statusmeldungen angezeigt. Bei einigen Sprachmodulen werden in diesem Fenster auch die im Code generierten Debugzeichenfolgen angezeigt.

Es gibt darüber hinaus einige weitere Fenster, die beim Debuggen in bestimmten Situationen je nach dem betroffenen Anwendungstyp und je nach Sprachmodul eingesetzt werden.

  • Bei Multithreading-Anwendungen können Sie im Thread-Fenster den aktuellen Ausführungs-Thread ändern oder die Threads in beliebigen angefügten Prozessen anzeigen. Der Inhalt der anderen beim Debuggen eingesetzten Fenster ändert sich entsprechend dem ausgewählten Thread.

  • Im Aufrufliste-Fenster wird eine Liste der aktiven Prozeduren oder Stack-Rahmen des aktuellen Ausführungs-Threads angezeigt. Die aktiven Prozeduren sind die in einem Prozess noch unvollständigen Prozeduren. Bei Internet-Anwendungen wird im Fenster Laufende Dokumente eine Liste der Dokumente angezeigt, die momentan in den ausgeführten Prozess geladen werden. Wenn Sie z.B. eine HTML-Rahmengruppe in den Browser laden, zeigt Ihnen das Fenster Laufende Dokumente, welche Seiten momentan geladen sind.


Beenden einer Debug-Sitzung

Eine Debug-Sitzung wird beendet, wenn alle von Ihnen gedebuggten Prozesse abgeschlossen sind. Sie können eine Debug-Sitzung auch mit einer der folgenden Methoden beenden:

So beenden Sie eine Debug-Sitzung

  • Wählen Sie aus dem Menü Debuggen den Befehl Fortfahren, um in den Ausführungsmodus zu wechseln und ab der aktuellen Codezeile mit der Ausführung der Anwendung fortzufahren.

    - Oder -

  • Wählen Sie aus dem Menü Debuggen den Befehl Neu starten, um den Prozess in der Debug-Sitzung zu beenden und die Anwendung vom Anfang neu zu starten.

    - Oder -

  • Wählen Sie aus dem Menü Debuggen den Befehl Beenden, um die Anwendung zu beenden und zum Entwurfsmodus zurückzukehren.


Wechsel in den Haltemodus bei einer Problemanweisung

Der Haltemodus hält die Operation einer Anwendung an und zeigt Ihnen eine Momentaufnahme ihres Zustands. Die Einstellungen von Variablen bleiben erhalten, so dass Sie den aktuellen Zustand der Anwendung analysieren und Änderungen eingeben können, die sich auf die Ausführung der Anwendung auswirken. Wenn eine Anwendung sich im Haltemodus befindet, können Sie Folgendes tun:

  • Den Code in der Anwendung ändern.

  • Den Zustand der Anwendungsoberfläche beobachten.

  • Feststellen, welche aktiven Prozeduren aufgerufen wurden.

  • Die Werte von Variablen und Ausdrücken überwachen.

  • Die Werte von Variablen ändern.

  • Anzeigen oder steuern, welche Anweisung die Anwendung als Nächste ausführt.

  • Anweisungen sofort ausführen.

  • Die Operation der Anweisung manuell steuern.

So wechseln Sie zur Laufzeit in den Haltemodus

  • Wählen Sie aus dem Menü Debuggen den Befehl Unterbrechen.

    Die Ausführung kann unterbrochen werden, wenn die Anwendung untätig ist (d.h. sich zwischen der Verarbeitung von Ereignissen befindet). In diesem Fall stoppt die Ausführung, wenn die nächste Codezeile ausgeführt werden soll.

    - Oder -

  • Legen Sie im Code im Text-Editor-Fenster einen Haltepunkt fest, oder definieren Sie im Dialogfeld Haltepunkt einen Haltepunkt.

    Wenn das Programm zur Laufzeit auf einen Haltepunkt stößt, wechselt es in den Haltemodus, bevor die Codezeile, in der der Haltepunkt gesetzt wurde, ausgeführt wird.

    - Oder -

  • Positionieren Sie programmgesteuert eine Anweisung im Code. Der Befehl zum Wechsel in den Haltemodus ist von Sprache zu Sprache verschieden. Weitere Informationen über eine bestimmte Sprache finden Sie in den Themen zum Debuggen der entsprechenden Sprache.

So wechseln Sie zur Entwurfszeit in den Haltemodus

  • Wählen Sie aus dem Menü Debuggen den Befehl Einzelschritt.

    Die Anwendung wechselt in der ersten Codezeile in den Haltemodus.

    - Oder -

  • Wählen Sie aus dem Menü Debuggen den Befehl Ausführen bis Cursor-Position.

    Die Anwendung wechselt in den Haltemodus, wenn sie die aktuelle Codezeile im Text-Editor-Fenster erreicht.

    Das genaue Verhalten des Haltemodus unterscheidet sich möglicherweise zwischen den verschiedenen Sprachmodulen oder bestimmten Anwendungstypen. Weitere Informationen finden Sie in den Themen zum Debuggen der entsprechenden Sprache.


Ausführen von Befehlen und Auswerten von Ausdrücken im Direktfenster

Verwenden Sie das Direktfenster, um Werte anzeigen und ändern zu können. Sie können beliebige Ausdrücke, Variablen oder Objekte im Fenster auswerten und den zurückgegebenen Wert anzeigen, oder Sie können die Auswirkung der von Ihnen eingegebenen Befehle (die die gleiche Sprache wie der momentan ausgeführte Code verwenden müssen) anzeigen.

Die Regeln zum Prüfen von Variablen und Eingeben von Befehlen variieren etwas zwischen den verschiedenen Sprachen. Weitere Informationen über eine bestimmte Sprache finden Sie im Thema zum Debuggen für die jeweilige Sprache.

Wenn Sie sich im Haltemodus befinden, können Sie den Fokus auf das Direktfenster richten, um Daten zu untersuchen. Im Direktfenster können Sie alle gültigen Ausdrücke, darunter Ausdrücke, die Eigenschaften oder Variablen enthalten, auswerten. Die momentan für die Aufrufliste aktive Prozedur definiert den Gültigkeitsbereich.

Sie können im Direktfenster auch Befehle eingeben, um Prozeduren auszuführen oder den Wert von Variablen oder Eigenschaften zu ändern. Diese Befehle werden sofort ausgeführt. Die Syntax und die Regeln zum Ausführen von Befehlen sind vom Sprachmodul abhängig.

So führen Sie eine Anweisung erneut aus

  • Positionieren Sie die Einfügemarke wieder auf der Anweisung. Sie können die aktuelle Anweisung bearbeiten, um ihre Wirkung zu ändern, und dann aus dem Menü Debuggen den Befehl Nächste Anweisung festlegen wählen.

So bewegen Sie sich im Direktfenster

  • Verwenden Sie die Maus oder die Pfeiltasten. Wie Sie sich mit der Tastatur im Direktfenster bewegen, finden Sie unter "Tastenkombinationen im Direktfenster".

    Drücken Sie EINGABE nur bei einer Anweisung, die Sie ausführen möchten.


Untersuchen von Variablen und Eigenschaften mit dem Überwachungsfenster

Mit Überwachungsausdrücken können Sie die Werte von Variablen, Eigenschaften und Ausdrücken zur Laufzeit überwachen. Viele Debugprobleme können nicht direkt auf eine einzelne Anweisung zurückgeführt werden, so dass Sie möglicherweise einen Überwachungsausdruck verwenden müssen, um das Verhalten einer Variablen oder eines Ausdrucks im Verlauf einer Prozedur beobachten zu können.

Die Entwicklungsumgebung überwacht die von Ihnen definierten Überwachungsausdrücke automatisch. Wenn die Anwendung in den Haltemodus wechselt, werden diese Überwachungsausdrücke im Fenster Überwachung angezeigt, in dem Sie ihre Werte beobachten können.

So fügen Sie zur Entwurfszeit oder im Haltemodus einen Überwachungsausdruck hinzu

  • Ziehen Sie einen Ausdruck oder eine Variable aus einem Text-Editor-Fenster in das Fenster Überwachung.

    - Oder -

  • Geben Sie einen gültigen Ausdruck im Fenster Überwachung ein.


IntelliMouse-Unterstützung

Mit der Microsoft® IntelliMouse™ können Sie in der Entwicklungsumgebung von zusätzlichen Navigationsfunktionen profitieren. Die IntelliMouse ist ein Zeigegerät mit einer Radsteuerung zwischen den beiden Maustasten. Die Radsteuerung stellt gleichzeitig ein Rad und eine Maustaste dar, so dass gängige Navigationsfunktionen einfach mit der Maus durchgeführt werden können.

Sie können Folgendes tun:

  • Das Rad drehen, um den Bildlauf in einem Fenster schneller als über die Bildlaufleisten vornehmen zu können.

  • Das Rad drücken und die Maus bewegen, um einen glatten vertikalen Bildlauf durchzuführen. Dies wird als Schwenken bezeichnet.

  • Auf die Radtaste klicken, um in den automatischen Bildlaufmodus zu wechseln und zu navigieren, ohne die Maustaste zu drücken.

Sie können das Rad der IntelliMouse in folgenden Bereichen einsetzen:

  • Im Text-Editor-Fenster

  • Im Direktfenster

  • Im Lokal-Fenster

  • Im Objektkatalog

  • Im Projekt-Explorer

  • Im Eigenschaftenfenster

  • Im Überwachungsfenster

  • In Webdokumenten


Verknüpfen von Fenstern

In der Entwicklungsumgebung können Sie Werkzeugfenster übereinander ziehen, um verknüpfte Fenster zu erstellen. Werkzeugfenster sind Fenster, die von jeder Entwicklungssprache definiert werden (z.B. die Werkzeugsammlung). Es gibt zwei Arten von Werkzeugfenstern:

  • Verknüpfte Fenster werden als ein einziges Fenster angezeigt, wobei die Titelleiste jedes Fenster von dem anderen trennt.

  • Verknüpfte Fenster mit Registerkarten werden als ein einziges Fenster mit einer Gruppe von Registerkarten angezeigt, mit denen Sie zu den anderen verknüpften Fenstern gelangen.

Sie können verknüpfte Fenster oder verknüpfte Fenster mit Registerkarten erstellen und trennen und die Registerkarten von verknüpften Fenstern mit Registerkarten neu anordnen.

So erstellen Sie ein verknüpftes Fenster

  • Klicken Sie auf die Titelleiste des Werkzeugfensters, das Sie verknüpfen möchten, und ziehen Sie es dann an eine Seite des Fensters, mit dem es verknüpft werden soll.

    Sie können Fenster horizontal oder vertikal oder mit der rechten bzw. linken Seite des Zielfensters verknüpfen.

So trennen Sie verknüpfte Fenster

  • Klicken Sie auf die Titelleiste, und ziehen Sie das Fenster aus dem verknüpften Fenster heraus.

    - Oder -

  • Doppelklicken Sie auf die Titelleiste.

So erstellen Sie verknüpfte Fenster mit Registerkarten

  • Klicken Sie auf die Titelleiste des Werkzeugfensters, das Sie verknüpfen möchten, und ziehen Sie es zur Titelleiste des Fensters, zu dem Sie eine Verknüpfung mit Registerkarte erstellen möchten.

    Beim Ziehen des Fensters über die entsprechende Stelle wird der Umriss einer Registerkarte angezeigt.

So trennen Sie verknüpfte Fenster mit Registerkarten

  • Klicken Sie auf die Registerkarte des Fensters, das Sie trennen möchten, und ziehen Sie es aus der Gruppe der Verknüpfungen mit Registerkarte.

So ordnen Sie Registerkarten neu

  • Ziehen Sie die zu verschiebende Registerkarte an die neue Position.

    Die aktive Registerkarte "rastet" an der gewünschten Position ein, und die anderen Registerkarten werden auf ihre linke bzw. rechte Seite verschoben.


Kennzeichen

Das Text-Editor-Fenster enthält Kennzeichen, die während der Bearbeitung des Codes visuelle Hinweise auf bestimmte Aktionen geben.

Die Kennzeichen werden in der Kennzeichenleiste angezeigt, die sich am linken Rand des Text-Editor-Fensters befindet. Sie können die Kennzeichenleiste im Dialogfeld Optionen auf der Seite Allgemein der Text-Editoroptionen aktivieren und deaktivieren.

Kennzeichen | Name | Angabe
 | Aktivierter Haltepunkt | Ein Haltepunkt, den Sie mit dem Befehl Haltepunkt einfügen aus dem Menü Debuggen festlegen. Sie können den Haltepunkt ein-/ausschalten, indem Sie den Mauszeiger auf der Kennzeichenleiste positionieren und klicken.
 | Aktuelle Ausführungszeile | Die Codezeile, die als nächste ausgeführt wird. Sie können dieses Kennzeichen in beliebigem laufenden Code an eine neue Stelle ziehen, um die als nächste auszuführende Codezeile zu markieren. Wenn Sie das Kennzeichen "Aktuelle Ausführungszeile" in einen ungültigen Bereich oder eine ungültige Zeile ziehen, passiert nichts, und das Kennzeichen kehrt an die ursprüngliche Position zurück.
 | Lesezeichen | Die Position des Lesezeichens, die mit dem Befehl Lesezeichen ein/aus aus dem Menü Bearbeiten festgelegt wird.
 | Aufrufliste-Marke | Zeilen, die sich momentan in der Aufrufliste befinden, und die aktuelle Codezeile, die als nächste ausgeführt werden soll. Dieses Kennzeichen wird nur im Haltemodus angezeigt.
 | Deaktivierter Haltepunkt | Die Position eines Haltepunkts, der deaktiviert wurde und beim Ausführen des Codes ignoriert wird.
 | Ungültiger Haltepunkt | Es gibt einen ungültigen Haltepunkt. Dieser wird beim Ausführen des Codes ignoriert.


Anhalten der Anwendungsausführung mit Haltepunkten

Um die Ausführung Ihrer Anwendung zu steuern, setzen Sie Haltepunkte. Hierbei handelt es sich um Stellen, an denen der Code anhalten und den Debugger aufrufen sollte. Sie können Haltepunkte zur Entwurfs- oder Laufzeit setzen oder entfernen.

So setzen oder entfernen Sie einen Haltepunkt

  • Bewegen Sie die Einfügemarke im Text-Editor-Fenster in die Codezeile, in der Sie einen Haltepunkt setzen oder löschen möchten, und klicken Sie in den Auswahlrand.

    - Oder -

  • Wählen Sie aus dem Menü Debuggen den Befehl Haltepunkt einfügen.

    - Oder -

  • Wählen Sie aus dem Menü Debuggen den Befehl Haltepunkte, um das Dialogfeld Haltepunkte einzublenden.

Wenn Sie einen Haltepunkt setzen, wird im Auswahlrand des Text-Editor-Fensters neben der Zeile, die den Haltepunkt enthält, ein roter Punkt angezeigt.

Nach dem Festlegen der Haltepunkte können Sie die Anwendung in der Entwicklungsumgebung ausführen. Wenn die Ausführung am ersten Haltepunkt angelangt ist, hält der Code an und startet den Debugger. Die nächste auszuführende Zeile wird im Text-Editor-Fenster im Auswahlrand durch einen gelben Pfeil gekennzeichnet.

Nachdem ein Haltepunkt erreicht wurde, können Sie einzelne Zeilen in Ihrem Code, d.h. Einzelschritte, ausführen. Während Sie sich schrittweise durch die Zeilen bewegen, wird der Code ausgeführt, und Sie sehen die Auswirkung jeder Zeile.

Anmerkung Wenn Sie den Debugger bei Office-Dokumenten ausführen, werden alle Haltepunkte automatisch gelöscht, nachdem das Dokument gespeichert oder aktualisiert wurde.


Reguläre Ausdrücke

Reguläre Ausdrücke stellen eine knappe und flexible Notation zum Suchen und Ersetzen von Textmustern dar. In der folgenden Tabelle werden reguläre Ausdrücke aufgeführt, die in die Felder Suchen oder Ersetzen eingefügt werden können. Sie können die folgenden regulären Ausdrücke eingeben. Verwenden Sie reguläre Ausdrücke zum Verfeinern und Erweitern Ihrer Suche.

Hinweis Sie müssen auf die Schaltfläche Regulärer Ausdruck klicken, bevor Sie einen der folgenden Ausdrücke als Teil der Suchkriterien verwenden.

Ausdruck | Syntax | Beschreibung
Zeilenbeginn | ^ | Startet die Übereinstimmung am Zeilenbeginn. Ist nur am Anfang eines Ausdrucks von Bedeutung.
Oder | | | Prüft den Ausdruck vor oder nach dem | auf Übereinstimmung. Wird hauptsächlich in einer Gruppe verwendet, z.B. "(Rücken)|(Fuß)massage" entspricht "Rückenmassage" und "Fußmassage".
Zeilenende | $ | Verankert die Übereinstimmung am Zeilenende. Ist nur am Ende eines Ausdrucks von Bedeutung.
Nicht im Zeichensatz enthaltenes Zeichen | [^] | Prüft ein beliebiges, nicht im Zeichensatz enthaltenes Zeichen, das auf ^ folgt, auf Übereinstimmung.
Markierter Ausdruck | {} | Markiert den übereinstimmenden Text mit dem Ausdruck in Klammern. Sie können andere Vorkommnisse des markierten Texts in einem Suchen-Ausdruck auf Übereinstimmung prüfen oder den markierten Text mit \N in einen Ersetzen-Ausdruck einfügen.
Gruppieren | () | Gruppiert einen untergeordneten Ausdruck.
N-ter markierter Text | \N | In einem Suchen-Ausdruck wird der Text, der dem N-ten markierten Ausdruck entspricht, auf Übereinstimmung geprüft, wobei N eine Zahl zwischen 1 und 9 ist. In einem Ersetzen-Ausdruck, wird der Text, der dem N-ten markierten Ausdruck entspricht, eingefügt, wobei N eine Zahl zwischen 1 und 9 ist. \0 fügt den Text ein, der dem gesamten Suchen-Ausdruck entspricht.
Beliebiges Zeichen | . | Prüft ein beliebiges einzelnes Zeichen auf Übereinstimmung.
Ein oder mehrere | + | Prüft mindestens ein Vorkommnis des vorhergehenden Ausdrucks auf Übereinstimmung.
Maximum von einem oder mehreren | # | Prüft mindestens ein Vorkommnis des vorhergehenden Ausdrucks auf Übereinstimmung und prüft dabei möglichst viele Zeichen auf Übereinstimmung.
Escape | \ | Prüft das auf den umgekehrten Schrägstrich (\) folgende Zeichen auf Übereinstimmung. Damit können Sie in einer regulären Ausdrucksnotation verwendete Zeichen, wie z.B. { and ^, finden.
Übereinstimmung verhindern | ~X | Verhindert die Prüfung der Übereinstimmung, wenn an dieser Stelle im Ausdruck X angezeigt wird. "Fuß~(ball)" entspricht z.B. "Fuß" in "fußkrank" und "Fußmassage," nicht aber "Fuß" in "Fußball."
N Mal wiederholen | ^N | Prüft N Vorkommnisse des vorhergehenden Ausdrucks auf Übereinstimmung. "[0-9]^4" entspricht z.B. einer beliebigen vierziffrigen Folge.
Zeichensatz | [] | Prüft ein beliebiges in den eckigen Klammern [] enthaltenes Zeichen auf Übereinstimmung. Um einen Zeichenbereich festzulegen, führen Sie die Anfangs- und Endzeichen durch einen Bindestrich (-) getrennt auf, wie z.B. [a-z].
Alphanumerisches Zeichen | :a | Prüft den Ausdruck ([a-zA-Z0-9]) auf Übereinstimmung.
Buchstabe | :c | Prüft den Ausdruck ([a-zA-Z]) auf Übereinstimmung.
Dezimalzahl | :d | Prüft den Ausdruck ([09]) auf Übereinstimmung.
Hexadezimalzahl | :h | Prüft den Ausdruck ([0-9a-fA-F]+) auf Übereinstimmung.
Bezeichner | :I | Prüft den Ausdruck ([a-zA-Z-$][a-zA-Z0-9_$]*-) auf Übereinstimmung.
Relationale Zahl | :n | Prüft den Ausdruck (([0-9]+.[0-9]*)|([0-9]*.[0-9]+)|([0-9]+)) auf Übereinstimmung.
Zeichenfolge in Anführungszeichen | :q | Prüft den Ausdruck (("[~"]*")|('[~']*')) auf Übereinstimmung.
Alphabetische Zeichenfolge | :w | Prüft den Ausdruck ([a-zA-Z]+) auf Übereinstimmung.
Dezimale Ganzzahl | :z | Prüft den Ausdruck ([0-9]+) auf Übereinstimmung.
Tabulatorzeichen | \t | Prüft ein Tabulatorzeichen, Unicode U+0009, auf Übereinstimmung.
Unicode-Zeichen | \x#### oder \u#### | Prüft ein vom Unicode-Wert gegebenes Zeichen auf Übereinstimmung, wobei #### 1 bis 4 hexadezimalen Ziffern entspricht.
Null oder mehr | * | Prüft Null oder mehr Vorkommnisse des vorhergehenden Ausdrucks auf Übereinstimmung.
Maximal Null oder mehr | @ | Prüft Null oder mehr Vorkommnisse des vorhergehenden Ausdrucks auf Übereinstimmung und stimmt möglichst viele Zeichen ab.


Wiederverwenden der aktuellen Dokumentfenster

Die Wiederverwendung des aktuellen Dokumentfensters ist eine praktische Methode, die Anzahl der in Ihrem Arbeitsbereich geöffneten Fenster auf ein Mindestmaß zu reduzieren. Wenn Sie z.B. ein Projekt debuggen und die Option zur Wiederverwendung nicht ausgewählt haben, könnten zu einem bestimmten Zeitpunkt viele Fenster geöffnet sein. Wenn Sie die Option zum Wiederverwenden wählen, wäre lediglich ein Dokumentfenster geöffnet.

So können Sie das aktuelle Dokumentfenster wiederverwenden

  1. Wählen Sie aus dem Menü Extras den Befehl Optionen.

  2. Wählen Sie in der Strukturansicht unter Umgebung die Seite Allgemein.

  3. Aktivieren Sie die Option Aktives Dokumentfenster wiederverwenden, falls gespeichert.

Wenn diese Option aktiviert ist, wird das aktuelle Dokumentfenster als Browser ausgeführt. Die Verwendung des aktuellen Dokumentfensters als Browser hat keinen Einfluss auf den Inhalt Ihres Dokumentfensters. Das Dokument im aktuellen Dokumentfenster wird jedes Mal beim Öffnen eines Dokumentfensters geschlossen. Wenn Sie den Inhalt eines Dokuments bearbeiten und es nicht speichern, während Sie das aktuelle Dokumentfenster wiederverwenden, gehen die Änderungen nicht verloren. Wenn Sie ein neues Dokumentfenster öffnen, wird es in einem anderen Dokumentfenster angezeigt, und im Arbeitsbereich gibt es jetzt zwei Dokumentfenster. Sie haben immer noch die Möglichkeit, die Änderungen zu speichern und das vorige Dokumentfenster zu schließen.


Festlegen von Optionen für den Editor

Sie können viele der Standardeinstellungen für den Text-Editor Ihren Bedürfnissen entsprechend ändern. Die Verfügbarkeit einiger Einstellungen hängt von der Sprache ab, so dass Sie den Text-Editor für jede verwendete Entwicklungssprache anders konfigurieren können. Andere Einstellungen sind global und gelten für alle Instanzen des Text-Editors, unabhängig vom Sprachmodul. Sie können die Optionen im Dialogfeld Optionen festlegen oder ändern.

So öffnen Sie das Dialogfeld Optionen

  • Wählen Sie Optionen aus dem Menü Extras.

Die Optionen für den Text-Editor werden in der Strukturansicht des Dialogfeldes Optionen unterhalb des Text-Editor-Knotens angezeigt. Wenn Sie einen Knoten in der Strukturansicht wählen, werden die entsprechenden Optionen in der rechten Fensterhälfte des Dialogfeldes Optionen angezeigt.

So legen Sie globale Optionen fest

  • Wählen Sie einen Knoten auf der ersten Ebene unterhalb des Text-Editor-Knotens. Wenn unterhalb des gewählten Knotens Knoten der zweiten Ebene angezeigt werden, setzen die für den Knoten auf der ersten Ebene festgelegten Optionen alle entsprechenden sprachspezifischen Einstellungen für den Knoten auf der zweiten Ebene außer Kraft.

So legen Sie sprachspezifische Optionen fest

  • Wählen Sie einen Knoten auf der zweiten Ebene unterhalb des Text-Editor-Knotens. Alle hier vorgenommenen Einstellungen haben nur für die gewählte Sprache Vorrang vor den entsprechenden Einstellungen auf der ersten Ebene.

    Anmerkung Wenn Sie anschließend eine Option für einen Knoten auf der ersten Ebene ändern, werden die entsprechenden sprachspezifischen Einstellungen (falls zutreffend) außer Kraft gesetzt.


Schrittweises Ausführen von Code zum Verfolgen des Ablaufs der Ausführung

Wenn Sie eine Stelle in Ihrem Code suchen, die eine andere Prozedur (eine Funktion, Unterroutine oder das mit einem Objekt oder Applet verknüpfte Skript) aufruft, können Sie in die Prozedur wechseln (Einzelschritt) oder sie ausführen (Prozedurschritt) und an der nächsten Zeile stoppen. Sie können an einer beliebigen Stelle zum Ende der aktuellen Prozedur springen (Prozedur abschließen) und mit dem Rest der Anwendung fortfahren.

Es kann sein, dass Sie sich schrittweise durch Ihren Code bewegen und den Ablauf der Code-Ausführung verfolgen möchten, weil es nicht immer offensichtlich ist, welche Anweisung zuerst ausgeführt wird. Sie haben folgende Möglichkeiten, um die Ausführung von Code nachzuvollziehen:

  • Einzelschritt: Verfolgt den Ablauf durch jede Codezeile und wechselt zu Prozeduren. Damit können Sie die Auswirkung jeder Anweisung auf Variablen anzeigen.

  • Prozedurschritt: Führt jede Prozedur aus, als handele es sich dabei um eine Einzelanweisung. Verwenden Sie diese Option anstelle von Einzelschritt, um Prozeduraufrufe zu überspringen und nicht in die aufgerufene Prozedur zu gehen.

  • Prozedur abschließen: Führt den gesamten verbleibenden Code in einer Prozedur aus, als handele es sich dabei um eine Einzelanweisung, und geht beim Verlassen zur nächsten Anweisung in der Prozedur, die die Prozedur ursprünglich aufrief.

  • Ausführen bis Cursor-Position: Ermöglicht Ihnen, eine Anweisung in Ihrem Code auszuwählen, an der die Ausführung gestoppt werden soll. Damit können Sie Codeabschnitte (z.B. große Schleifen) "überspringen".

So verfolgen Sie den Ablauf der Ausführung ab der aktuellen Anweisung

  • Wählen Sie aus dem Menü Debuggen die Befehle Einzelschritt, Prozedurschritt, Prozedur abschließen oder Ausführen bis Cursor-Position.

So verfolgen Sie den Ablauf der Ausführung ab Programmbeginn

  • Wählen Sie aus dem Menü Debuggen die Befehle Einzelschritt, Prozedurschritt, Prozedur abschließen oder Ausführen bis Cursor-Position.


Tipps zum Debuggen

So vereinfachen Sie das Debuggen

  • Wenn Ihre Anwendung nicht die richtigen Ergebnisse produziert, durchsuchen Sie den Code auf Anweisungen, die das Problem möglicherweise verursacht haben. Setzen Sie an diesen Anweisungen Haltepunkte, und starten Sie die Anwendung neu.

  • Wenn das Programm anhält, testen Sie die Werte wichtiger Variablen und Eigenschaften. Untersuchen Sie Variablen und Ausdrücke im Direktfenster.

So finden Sie einen schwierigen Programmfehler

  • Erstellen Sie als Erstes unbedingt eine Sicherungskopie, denn hier geht selbst erfahrenen Programmieren am häufigsten die Arbeit mehrerer Stunden verloren. Beim Experimentieren passiert es ganz leicht, dass notwendige Codeabschnitte versehentlich überschrieben oder gelöscht werden.

  • Verwenden Sie die in der Entwicklungsumgebung integrierten Debugfunktionen. Versuchen Sie, die Codezeile(n) zu identifizieren, die den Fehler generieren. Isolieren Sie den Code. Wenn Sie das Problem auf einen Codeblock beschränken können, versuchen Sie, das gleiche Problem erneut mit dem gleichen Codeblock, aber vom Rest des Programms getrennt, zu produzieren.

  • Vereinfachen Sie das Problem. Entfernen Sie, falls möglich, Komponenten von Drittherstellern aus dem Projekt. Eliminieren Sie allen Code, der aller Wahrscheinlichkeit nach nichts mit dem Problem zu tun hat.

  • Wenn Sie keine Lösung finden und das Problem mit keiner dieser Methoden isolieren oder lösen können, sollten Sie sich nach Hilfe umsehen. Siehe "Technischer Support" in der Dokumentation.


Verwenden des Text-Editors

Im Texteditor-Fenster können Sie Code-, Skript-, HTML- oder Textdokumente schreiben, anzeigen und bearbeiten. Sie können mehrere Text-Editor-Fenster öffnen. So können Sie Code problemlos in verschiedenen Modulen ansehen und zwischen diesen kopieren und einfügen. Alle geöffneten Text-Editor-Fenster sind in der über das Menü Fenster verfügbaren Fensterliste aufgeführt.

So öffnen Sie ein Code-Editor-Fenster

  • Wählen Sie ein Codemodul oder Dokument im Fenster Projekt-Explorer, und klicken Sie auf die Symbolleistenschaltfläche Code anzeigen.

    - Oder -

  • Wählen Sie ein Codemodul oder Dokument im Fenster Projekt-Explorer, und wählen Sie Code aus dem Menü Ansicht.

Funktionen des Text-Editors

Im Text-Editor gibt es verschiedene Funktionen, die das Schreiben und Bearbeiten von Code vereinfachen. Die verfügbaren Funktionen variieren je nach Sprachmodul und den Einstellungen der Text-Editor-Optionen.

Ziehen und Ablegen

Sie können ausgewählten Text oder einen Codeblock ziehen, um ihn zu verschieben, zu kopieren oder zu löschen. Sie können auch bestimmte Codeelemente, wie z. B. Variablen oder Anweisungen, ziehen, um sie zu debuggen.

So verschieben Sie Text

  • Wählen Sie den gewünschten Text, und ziehen Sie ihn an eine neue Stelle im aktuellen Text-Editor-Fenster oder in ein anderes Text-Editor-Fenster.

So kopieren Sie Text

  • Wählen Sie den gewünschten Text, und ziehen Sie ihn bei gedrückter STRG-Taste an eine neue Stelle im aktuellen Text-Editor-Fenster oder in ein anderes Text-Editor-Fenster.

So löschen Sie Text

  • Wählen Sie den gewünschten Text, und ziehen Sie ihn in den Windows-Papierkorb.

So debuggen Sie eine Variable oder Anweisung

  • Wählen Sie eine Variable oder Anweisung, und ziehen Sie sie zum Überwachungsfenster oder zum Direktfenster.

Anweisungsergänzung

Die Anweisungsergänzung unterstützt Sie beim Schreiben des Codes. Die verfügbaren Anweisungsergänzung-Optionen variieren je nach dem verwendeten Sprachmodul und den Einstellungen der Text-Editor-Optionen. Schlagen Sie in der Dokumentation zu Ihrer Sprache nach.

Liste der Objektelemente

Die Liste der Objektelemente ist ein Dropdown-Listenfeld, das die für ein gewähltes Objekt verfügbaren Eigenschaften und Methoden enthält. Wenn Sie einen Objektnamen unter Verwendung der Syntax Objekt.Element eingeben, wird die Liste angezeigt, nachdem Sie den Punkt eingegeben haben.

Um ein Element zu wählen, geben Sie den/die ersten Buchstaben seines Namens an, bis das gewünschte Element hervorgehoben wird. Sie können sich auch über die Tasten NACH OBEN, NACH UNTEN, BILD AUF, BILD AB, STRG+BILD AUF, oder STRG+BILD AB durch die Liste bewegen.

Wenn Sie das gewünschte Element gewählt haben, wird das aktuelle Element durch Betätigen einer beliebigen Trennzeichentaste bestätigt und in Ihrem Code eingefügt. Der Tastenanschlag für das Trennzeichen wird ebenfalls wie gezeigt im Anschluss an das Element eingefügt:

Trennzeichen-taste | Ergebnis
Tabulatortaste | Bestätigt das gewählte Element. Die Einfügemarke befindet sich unmittelbar hinter Element.
Leertaste | Bestätigt das gewählte Element gefolgt von einer Leerstelle.
Eingabetaste | Bestätigt das gewählte Element und positioniert die Einfügemarke am Anfang einer neuen Zeile.
Kommataste | Bestätigt das gewählte Element gefolgt von einem Komma.

Wenn kein Element hervorgehoben ist, wird das aktuelle Element in der Liste durch die Tabulatortaste oder STRG+EINGABETASTE bestätigt.

Ganzes Wort

Vervollständigt das Wort, das Sie eingeben, sobald so viele Buchstaben vorhanden sind, dass der Editor das gewünschte Wort erkennt.

Parameterinformationen

Gibt Informationen über die Parameter der ersten Funktion oder Anweisung. Wenn es eine Funktion oder Anweisung gibt, die Funktionsaufrufe als Parameter enthält, erhalten Sie über Parameterinfo Informationen über die erste Funktion. QuickInfo gibt Informationen zu jeder eingebetteten Funktion.

Während das Fenster Parameterinfo angezeigt wird, führt die Eingabe eines Kommas (,) dazu, dass der nächste Parameter fett angezeigt wird.

Ist das Fenster Parameterinfo aktiviert, wird es erst geschlossen, wenn:

  • alle erforderlichen Parameter eingegeben wurden.

  • die Funktion ohne Verwendung aller optionalen Parameter beendet wurde.

  • Sie die ESC-Taste drücken.

Konstanten anzeigen

Öffnet eine Dropdown-Liste mit Konstanten für eine Eigenschaft oder einen Parameter. Nach der Eingabe des Namens einer Eigenschaft oder eines Parameters wird die Liste aufgeklappt und zeigt die verfügbaren Konstanten an.


Verwenden des Objektkatalogs

Mit dem Objektkatalog sind Sie beim Durchsuchen und Filtern von und beim Suchen nach Komponenten, die möglicherweise in Ihren Projekten verwendet werden sollen, flexibel.

So rufen Sie den Objektkatalog auf

  1. Klicken Sie im Menü Ansicht auf Andere Fenster.

  2. Klicken Sie auf Objektkatalog.

Sie können beliebige Bibliotheken oder Pakete anzeigen, auf die vom aktuellen Projekt verwiesen werden kann. Je nach Art des Projekts und je nach verwendetem Sprachmodul, könnte es sich dabei z. B. um Folgendes handeln:

  • den Quellcode des aktuellen Projekts

  • Typbibliotheken für COM-Objekte, auf die verwiesen wird.

In der linken Fensterhälfte wird eine Liste aller Pakete oder Bibliotheken angezeigt. Jede/s kann erweitert werden, um die im Paket enthaltenen Klassen anzuzeigen. Die mit diesen Klassen verknüpften Elemente werden in der rechten Fensterhälfte angezeigt.

Sie können die Ansicht durch Einstellen des Mitgliedstyps, der Zugriffsgruppierung, der Filterung und der Anzeige anpassen.

  • Ansicht wechseln: Sie können den Inhalt und die Anzeige der linken Fensterhälfte ändern und Klassen und/oder Elemente anzeigen, und festlegen, ob diese in Paketen gruppiert oder alphabetisch aufgeführt werden. Durch Erweitern von Klassen wird ihre Vererbungsstruktur offen gelegt, in die Kategorien Übergeordnete Klassen, Unterklassen und Schnittstellen gruppiert, die wiederum erweitert werden und eine Vererbungsstruktur des entsprechenden Typs anzeigen.

  • Zu durchsuchende Gruppe ändern: Klicken Sie in der Befehlsleiste auf die Schaltfläche Aktuelle Pakete/Bibliotheken auswählen, um das Dialogfeld Pakete/Bibliotheken auswählen anzuzeigen. Das Dialogfeld Pakete/Bibliotheken auswählen enthält eine markierte Strukturansicht, über die der Benutzer sowohl das Projekt und COM-Komponenten, die sich auf dem Computer des Benutzers befinden, auswählen kann. Der Benutzer markiert die Bibliothek, die durchsucht werden soll, und klickt auf OK. Diese wird zur aktiven Bibliothek, wenn Sie wieder zum Hauptdialogfeld des Objektkatalogs zurückkehren. Standardmäßig werden nur die Bibliotheken durchsucht, auf die von den aktuellen Projekten verwiesen werden kann.

  • Suchen: Die Dropdown-Liste Klassen und Elemente filtern erlaubt dem Benutzer die Eingabe von Zeichenfolgen, anhand derer in der linken Fensterhälfte gefiltert werden soll. Wenn der Benutzer z. B. "MyEvent" eingibt und die EINGABETASTE drückt, während Klassen angezeigt werden, werden alle Klassen, die den Begriff "MyEvent" enthalten in der linken Fensterhälfte angezeigt. Wenn der Benutzer dann zur Ansicht von Elementen umschaltet, werden nur die Mitglieder, die den Begriff "MyEvent" enthalten, angezeigt. Klicken Sie auf die Schaltfläche Filter entfernen, um den Inhalt des Filters zu löschen

  • Gruppieren und sortieren: Klicken Sie auf die Schaltfläche Gruppieren und sortieren, um Elemente und Klassen nach Typ und Zugriffsstatus zu gruppieren oder zu sortieren. Wenn Sie z. B. im Dialogfeld Gruppieren und sortieren in der Dropdown-Liste Mitglieder die Option Nach Mitgliedszugriff gruppieren wählen, wird eine Liste von Zugriffstypen, wie z. B. Öffentliche Mitglieder, Private Mitglieder und Geschützte Mitglieder, angezeigt. Sie können dann die Sortierfolge für diese Elemente festlegen. Darüber hinaus können Sie festlegen, ob die gruppierten Elemente in einer Struktur angezeigt werden sollen.

  • Beständigkeit: Der Objektkatalog erhält alle Bibliotheksverweise, die nicht zu den aktuellen Projekten gehören. Der Benutzer könnte z. B. einen Bibliotheksverweis auf eine COM-Bibliothek hinzufügen, die immer zum Durchsuchen verfügbar ist, unabhängig davon, welche Projekte geladen sind. Diese zusätzlichen Bibliotheksinformationen werden in der Registrierung gespeichert. Der durchsuchte Satz bleibt lösungsspezifisch erhalten. Sollten Pakete in einem durchsuchten Satz nicht mehr auf dem Computer registriert sein, werden sie aus dem durchsuchten Satz entfernt und nicht länger mit ihm erhalten.


Anzeigen einer Liste von laufenden Dokumenten

Im Fenster Laufende Dokumente wird eine Liste der HTML-Dokumente angezeigt, die in einem beliebigen angefügten Prozess aktiv sind, der HTML anzeigen kann, wie z.B. Internet Explorer. In diesem Fenster können Sie in HTML-Seiten eingebettete Skripts oder Komponenten mit Hilfe des Skript-Debuggers debuggen.

Sie können an jedes momentan ausgeführte Skript , das Skripts und Komponenten auf Seiten enthält, die nicht zum aktuellen Projekt gehören, anfügen. Sie können Skripts debuggen, die lokal auf Ihrem Computer ausgeführt werden, oder an Prozesse anfügen, die auf Remote-Computern ausgeführt werden, wie z.B. eine auf einem Server ausgeführte .asp-Seite.

Wenn keine Verbindung zu Prozessen besteht, ist das Fenster Laufende Dokumente leer.

So zeigen Sie das Fenster "Laufende Dokumente" an

  • Wählen Sie aus dem Untermenü Debug-Fenster des Menüs Ansicht den Befehl Laufende Dokumente.


Anzeigen lokaler Variablen im Lokal-Fenster

Im Lokal-Fenster werden die Werte und Typen aller Variablen angezeigt, die sich im Bereich der momentan ausgeführten Prozedur befinden. In diesem Fenster erhalten Sie Informationen über die Lebensdauer einer Variablen, während Sie sich schrittweise durch die Anwendung bewegen, da Sie sehen, wann sie initialisiert wird, wann sie sich ändert und wann sie zerstört wird. Wenn eine Variable in den Gültigkeitsbereich eintritt, wird sie im Fenster angezeigt. Sie bleibt solange sichtbar, wie sie sich im Gültigkeitsbereich befindet, und Wertänderungen werden wiedergegeben. Wenn die Variable den Gültigkeitsbereich verlässt, wird sie aus dem Lokal-Fenster entfernt.

Bei Sprachen, die mehrere Ausführungs-Threads unterstützen, können Sie die lokalen Variablen für einen bestimmten Thread anzeigen, indem Sie ihn aus der Thread-Liste auswählen.

So zeigen Sie das Lokal-Fenster an

  • Wählen Sie aus dem Untermenü Debug-Fenster des Menüs Ansicht den Befehl Lokal.


Anzeigen von Meldungen oder Ergebnissen im Ausgabefenster

Im Ausgabefenster werden vom Compiler generierte Meldungen angezeigt. Hier wird auch die aus den in Ihrem Code platzierten Debug-Anweisungen resultierende Ausgabe angezeigt. Der Ausgabetyp variiert möglicherweise etwas zwischen den verschiedenen Sprachen. Weitere Informationen über eine bestimmte Sprache finden Sie im Thema zum Debuggen für die jeweilige Sprache.

Die im Ausgabefenster angezeigte Ausgabe kann aus mehreren unterschiedlichen Quellen generiert worden sein. Die Ausgabe aus jeder Quelle wird auf einer separaten Seite innerhalb des Ausgabefenster angezeigt. Sie können zwischen den Ausgabeseiten wechseln, indem Sie sie aus der Liste am oberen Rand des Ausgabefensters wählen.

Der Inhalt des Ausgabefensters wird jedes Mal gelöscht, wenn Sie die Anwendung ausführen oder kompilieren. Sie können Text jederzeit aus dem Ausgabefenster ausschneiden, kopieren oder löschen.

So zeigen Sie das Ausgabefenster an

  • Wählen Sie aus dem Untermenü Andere Fenster des Menüs Ansicht den Befehl Ausgabe.


Anzeigen der Aufrufliste

Mit der Aufrufliste können Sie die Operation einer Anwendung mitverfolgen, während sie eine Reihe geschachtelter Prozeduren ausführt. Das Fenster Aufrufliste zeigt eine Liste aller aktiven Prozeduraufrufe oder Stack-Rahmen des aktuellen Ausführungs-Threads. Unter aktiven Prozeduraufrufen versteht man Prozeduren, die gestartet aber noch nicht abgeschlossen wurden. Die Aufrufliste positioniert den ältesten aktiven Prozeduraufruf am unteren Ende der Liste und fügt nachfolgende Prozeduraufrufe am Anfang der Liste hinzu.

Die für jede Prozedur gegebenen Informationen beginnen mit dem Namen der Prozedur, gefolgt vom Sprachmodul, das die Prozedur ausführt. Bei Multithreading-Anwendungen führt das Auswählen eines Threads aus der Thread-Liste zum Aktivieren dieses Threads und richtet den Fokus in der integrierten Entwicklungsumgebung auf diesen. Der Inhalt der Aufrufliste ändert sich, so dass die aktiven Prozeduraufrufe für den neu gewählten Thread wiedergegeben werden.

Anmerkung Wenn Sie die Anwendung während einer untätigen Schleife in den Haltemodus setzen, werden im Dialogfeld Aufrufliste keine Einträge angezeigt.

So zeigen Sie die Aufrufliste an

  • Wählen Sie aus dem Untermenü Debug-Fenster des Menüs Ansicht den Befehl Aufrufliste.


Leerstellen

Die folgenden Schriftzeichen werden angezeigt, wenn Sie die sichtbaren Leerstellen anzeigen, indem Sie die STRG-Taste gedrückt halten und RW drücken, oder indem Sie Weitere Optionen aus dem Menü Bearbeiten und dann Leerstellen anzeigen wählen.

Dieses Schriftzeichen | Repräsentiert
 | Leerstelle
 | Tabulator
 | Dateiende


Fensterverwaltung

Es gibt verschiedene Möglichkeiten zum Verwalten der Werkzeug- und Dokumentfenster in Ihrem Programm und zum Maximieren Ihres Arbeitsbereichs. Werkzeugfenster sind Fenster, die von der Entwicklungsumgebung (z.B. dem Projekt-Explorer) hinzugefügt werden. Dokumentfenster sind Fenster, die von Ihnen erstellte Elemente (z.B. eine HTML-Seite).) enthalten. Sie können Werkzeugfenster andocken bzw. verknüpfen, um Fenster möglichst übersichtlich anzuordnen. Sie haben auch die Möglichkeit, nur die benötigten Fenster anzuzeigen. Sie können darüber hinaus die Fenstervoreinstellungen anpassen, damit beim Öffnen der Entwicklungsumgebung nur die gewünschten Fenster angezeigt werden.

Darüber hinaus gibt es zwei Modi für die Entwicklungsschnittstelle: MDI (Multiple Document Interface) und SDI (Single Document Interface). Im MDI-Modus gibt es auf Ihrem Desktop ein Fenster, das die anderen geöffneten Fenster enthält. Im SDI-Modus wird jedes geöffnete Fenster separat auf dem Desktop angezeigt.

Fenster

Werkzeugfenster

Werkzeugfenster werden von der Anwendung und den Add-ins definiert. Die Werkzeugfenster sind im Menü Ansicht aufgeführt. Sie können ein- oder ausgeblendet, angedockt und verknüpft, außerhalb des Anwendungsbereichs verschoben und auf einem anderen Monitor angezeigt werden. Es ist zwar nicht möglich, ein Werkzeugfenster auf Vollbild- oder Symbolgröße zu ändern, Sie können aber seine Größe ändern. Die neue Größe gehört zur aktuellen Ansicht. Wenn ein Werkzeugfenster aktiv ist, können Sie Änderungen an ihm vornehmen. Sie können Werkzeugfenster andockbar oder nicht-andockbar machen, indem Sie den Befehl Andockbar aus dem Menü Fenster aktivieren bzw. deaktivieren. Wenn ein Werkzeugfenster andockbar ist, ist es im Vordergrund anderer Fenster frei beweglich oder es wird an einer Seite des Anwendungsfensters ausgerichtet. Um ein andockbares Fenster zu verschieben, ohne es an einer Stelle auszurichten, drücken Sie die STRG-Taste, während Sie das Fenster an die gewünschte Stelle ziehen. Wenn Werkzeugfenster nicht mehr andockbar sind, verhalten sie sich wie Dokumentfenster und werden in der Fensterliste des Menüs Fenster angezeigt.

Dokumentfenster

Dokumentfenster werden beim Öffnen oder Erstellen von Dateien oder anderen Elementen dynamisch erstellt. Wenn ein Dokumentfenster sichtbar ist, wird die Datei als geöffnet angesehen und kann bearbeitet werden. Durch Schließen eines Dokumentfensters wird auch die Datei geschlossen. Die aktuelle Liste von Dokumentfenstern wird im Menü Fenster in der Reihenfolge angezeigt, in der sie aktiviert wurden, wobei sich das momentan geöffnete Fenster oben in der Liste befindet. Links neben dem aktiven Dokumentfenster wird außerdem ein Häkchen angezeigt.

Dokumentfenster gibt es nur im verfügbaren Client-Bereich der Anwendung. Sie können Dokumentfenster schließen, ihre Größe ändern, sie auf Vollbild- oder Symbolgröße ändern, aber Sie können sie nicht ausblenden, verknüpfen oder andocken.

Verknüpfen von Fenstern

Sie können Werkzeugfenster miteinander verknüpfen, indem Sie ein Fenster über ein anderes ziehen. Es gibt zwei Arten der Verknüpfung: verknüpfte Fenster und verknüpfte Fenster mit Registerkarten. Wenn Sie Fenster horizontal verknüpfen, werden sie als ein Fenster angezeigt und durch die Titelleiste voneinander getrennt. Verknüpfte Fenster mit Registerkarten werden als ein Fenster mit Registerkarten angezeigt, mit denen Sie sich zu anderen verknüpften Fenstern bewegen können.

Mehrere Monitore

Auf Plattformen, die mehrere Monitore unterstützen, können Sie Ihre Fenster auf mehrere Monitore verschieben, indem Sie das Fenster auf andere Monitore ziehen. Sie können die Fenster auf den verschiedenen Monitoren an einer beliebigen Stelle positionieren; die Positionen werden gespeichert.

Modus "Ganzer Bildschirm"

Im Modus Ganzer Bildschirm wird das aktive Dokument auf Bildschirmgröße vergrößert, und alle Fensterelemente des Hauptanwendungsfensters, wie z.B. die Symbolleisten, die Titelleiste, die Werkzeugfenster, die Statusleiste und die Task-Leiste von Windows, werden ausgeblendet Die z-Folge bleibt erhalten, so dass die Liste von Fenstern in der Reihenfolge, in welcher sie geöffnet wurden, im Menü Fenster erhalten bleibt. Im Modus Ganzer Bildschirm durchgeführte Änderungen des Arbeitsbereiches werden beim Verlassen des Modus gespeichert.

So wechseln Sie zum Modus "Ganzer Bildschirm"

  • Wählen Sie Ganzer Bildschirm aus dem Menü Ansicht.

Wenn Sie sich im Modus Ganzer Bildschirm befinden, wird am oberen Fensterrand eine Symbolleiste mit der Schaltfläche Ganzer Bildschirm angezeigt. Klicken Sie auf die Schaltfläche Ganzer Bildschirm, um den Modus Ganzer Bildschirm zu verlassen.


Thema nicht gefunden

Es wurde kein entsprechendes Thema gefunden. Mögliche Ursachen und Problemlösungen hierfür sind z. B.:

  • Die Datei (.chm), die das Zielthema enthält, befindet sich nicht in dem erwarteten Verzeichnis.

    Problemlösung: Starten Sie erneut das Setup von MSDN Library.

  • Die Datei (.chm), die das aktuelle oder das Zielthema enthält, ist veraltet und die Verknüpfung ist nicht mehr gültig.

    Problemlösung: Installieren Sie die neueste Version von MSDN Library.

  • Die MSDN Library-CD befindet sich nicht im CD-ROM-Laufwerk.

    Problemlösung: Legen Sie die MSDN Library-CD in das CD-ROM-Laufwerk.


Filtern im Objektkatalog

Verwenden Sie die Dropdown-Liste Klassen und Elemente filtern, um eine Zeichenfolge einzugeben, die die aktuelle Ansicht beschränkt. Der Filter wird immer der linken Fensterhälfte zugewiesen. Wenn Sie z. B. "font" in der Dropdown-Liste Klassen und Elemente filtern eingeben, während Klassen angezeigt werden, werden in der linken Fensterhälfte nur Klassen angezeigt, die das Wort "font" enthalten. Um nach Elementen zu suchen, die "font" enthalten, klicken Sie auf die Schaltfläche Elemente anzeigen in der linken Fensterhälfte.

Der Filter ist standardmäßig eine übereinstimmende Zeichenfolge.

So weisen Sie einen neuen Filter zu

  1. Geben Sie eine Filterzeichenfolge in der Dropdown-Liste Klassen und Elemente filtern ein.

  2. Drücken Sie die EINGABETASTE, um den Filter zu initiieren.

Der Filter wird den Ansichten in der linken Fensterhälfte zugewiesen, bis er entfernt wird.

So wechseln Sie zum Anfang einer Wortübereinstimmung

  1. Geben Sie eine Filterzeichenfolge in der Dropdown-Liste Klassen und Elemente filtern ein.

  2. Klicken Sie in der Befehlsleiste auf die Schaltfläche Filter findet nur Wortanfang.

  3. Drücken Sie die EINGABETASTE, um den Filter zu initiieren.

Der Filter wird den Ansichten in der linken Fensterhälfte zugewiesen, bis er entfernt wird.

So entfernen Sie den zugewiesenen Filter

  • Klicken Sie auf die Schaltfläche Filter entfernen.

Damit wird sämtlicher Text in der Dropdown-Liste Klassen und Elemente filtern entfernt und der Inhalt der linken und rechten Fensterhälfte entsprechend aktualisiert.

Alle Schaltflächen der Befehlsleiste, die sich auf den angezeigten Inhalt auswirken, beeinflussen lediglich die linke Fensterhälfte. Die Schaltflächen Klassen anzeigen, Elemente anzeigen und die Einstellung "Nur Pakete" (Nach Paketen/Bibliotheken filtern deaktiviert) wirken sich direkt auf die Anzeige in der linken Fensterhälfte aus. Das Gruppieren und Sortieren wirkt sich auf die linke Fensterhälfte aus, wenn die gruppierten und sortierten Elemente im Fenster angezeigt werden.

Die Legende des Fensters reflektiert ihren Inhalt. Dazu zwei Beispiele:

  • Klassen und Elemente mit "Suchzeichenfolge" (Klassen, Elemente aktiviert, Übereinstimmende Zeichenfolgen nach "Suchzeichenfolge" filtern)

  • Nur Pakete (Klassen, Elemente deaktiviert, Nach Paketen/Bibliotheken filtern)


Anzeigen von Variablen im Auto-Fenster

Im Auto-Fenster werden die Werte aller Variablen, die sich im Gültigkeitsbereich der momentan ausgeführten Prozeduren befinden, angezeigt. Wenn im Lokal-Fenster Variablen für einen einzelnen Thread angezeigt werden, werden im Auto-Fenster Variablen für alle Threads angezeigt. In diesem Fenster können Sie sich über Änderungen an einer Variablen informieren, die durch Code in einem anderen Thread verursacht wurden. Eine Variable bleibt solange sichtbar, wie sie sich im Gültigkeitsbereich befindet, und spiegelt alle Änderungen an ihrem Wert wider. Wenn die Variable den Gültigkeitsbereich verlässt, wird sie aus dem Auto-Fenster entfernt.

So zeigen Sie das Auto-Fenster an

  • Wählen Sie Autos aus dem Untermenü Debug-Fenster des Menüs Ansicht.


Neuzuordnung der Tastatur

Das Tastaturzuordnungsschema definiert die Kombinationen von Tastenanschlägen, die bei der Arbeit in der integrierten Entwicklungsumgebung verwendet werden können.

So definieren Sie ein neues Tastaturzuordnungsschema

  1. Wählen Sie Optionen aus dem Menü Extras.

  2. Wählen Sie im Dialogfeld Optionen den Knoten Umgebung, Tastatur.

  3. Ändern Sie das Tastaturzuordnungsschema wie gewünscht, und geben Sie in der Dropdown-Liste Tastaturzuordnungsschema einen Namen für das neue Schema ein.

  4. Klicken Sie auf die Schaltfläche Speichern unter.


Schlüsselwort nicht gefunden

Das von Ihnen gesuchte Schlüsselwort wurde in der Dokumentation nicht gefunden. Das Schlüsselwort wurde entweder falsch geschrieben, es wurde zu viel oder zu wenig Text ausgewählt oder nach Hilfe zu einem Wort gesucht, das kein gültiges Schlüsselwort ist.

Das Schlüsselwort, zu dem Sie Hilfe wünschen, ist möglicherweise in einer Objektbibliothek enthalten, auf die es keinen Verweis gibt. Stellen Sie sicher, dass die Verweise auf die Objektbibliotheken für alle in Ihrem Code verwendeten Objekte festgelegt wurden.

Die einfachste Methode, Hilfe zu einem bestimmten Schlüsselwort zu erhalten, besteht darin, die Einfügemarke an einer beliebigen Stelle im Schlüsselwort zu positionieren und F1 zu drücken. Sie müssen das Schlüsselwort nicht auswählen. Wenn Sie nur einen Teil des Schlüsselwortes oder mehr als ein einzelnes Wort auswählen, findet die Hilfe nicht, wonach Sie suchen.

Wenn Sie z.B. F1 drücken, während sich die Einfügemarke zwischen dem "A" und dem "B" des Schlüsselworts TABLE befindet, wird im folgenden Beispiel eine Liste von Themen, die das Wort "table" enthalten, angezeigt. Sie können dann das gewünschte Thema auswählen.

<TABLE BORDER=1 CELLPADDING=1>

Sie können die Hilfe auch durchsuchen, um weitere Informationen zu einem Schlüsselwort zu erhalten.

So suchen Sie in der Hilfe nach einem Schlüsselwort

  1. Klicken Sie im Menü ? auf Suchen.
    2.